Webshop

Ecofont Software
system requirements


Operating system
Windows XP, Windows Vista, Windows 7, Windows 8 or Windows 10

Compatible with
Word and Outlook (2003 Professional, 2007, 2010, 2013 and 2016)

Fonts
Supports Arial, Verdana, Calibri, Times New Roman and Trebuchet.
share*it! Logo

Ecofont Software

Language:  
 
Ecofont Home and 3-pack
Save up to 50% ink and toner costs by printing your documents with Ecofont software. This software comes with The Standard Font Collection. Ecofont software includes even more inksaving options like printing without images or with images in greyscale, printing only the textselection and printing all text and tables in black.

Standard Font Collection
Supports Arial, Calibri, Times New Roman, Trebuchet MS, Verdana
productpicture
Platform:   Windows XP x32, Windows 7 x32, Windows 7 x64, Windows 8, Windows 8 x32, Windows 8 x64, Windows 7, Windows Vista x64, Windows Vista x32, Windows 8.1, Windows 10, Windows XP x64
Version:   Standard Font Collection
Language:   English, German, Portuguese, Spanish, Italian, French, Dutch, Turkish

Ecofont Home - 1 lifetime license
 
productpicture
Unit Price:   USD 19.95 
Total:   USD 19.95
 Info includes 0% sales tax/VAT to USD 19.95: USD 0.00
Delivery:   Download, License key
Language:   English, German, Portuguese, Spanish, Italian, French, Dutch, Turkish, (Installation in English)
File Size:   Full version: 17.7 MB
Download Time:   Full version
  • 56k: ~41 min.
  • DSL/Cable (1/8/16Mbit): ~2 / <1 / <1 min.

General requirements:   Compatible with:
Word & Outlook 2003 Professional
Word & Outlook 2007 All versions
Word & Outlook 2010 All versions
Word & Outlook 2013 All versions
Word & Outlook 2016 All versions

Check the system requirements for this software.
  Share on Facebook   Share on Twitter   Add to Cart  Buy now!
Ecofont 3 pack - lifetime license
 
productpicture
Unit Price:   USD 42.95 
Total:   USD 42.95
 Info includes 0% sales tax/VAT to USD 42.95: USD 0.00
Language:   English, German, Portuguese, Spanish, Italian, French, Dutch, Turkish, (Installation in English)
General requirements:   Compatible with:
Word & Outlook 2003 Professional
Word & Outlook 2007 All versions
Word & Outlook 2010 All versions
Word & Outlook 2013 All versions
Word & Outlook 2016 All versions

Check the system requirements for this software.
  Share on Facebook   Share on Twitter   Add to Cart  Buy now!